Support

Minimum requirements for starting a live.ly broadcasting

To go live on live.ly, your device should meet all the requirements below:

1. Android version 4.3 or above
2. CPU Dual-core 800 MHz or above
3. 384 MB RAM or above

For now, if your device doesn't meet any one of those requirements, you will not be able to start a live broadcast on live.ly.

Have more questions? Submit a request